Calc

Elaborations de formules complexes (avec figement des cellules)

 

Manipulation

La moyenne d’un élève est calculée à partir des coefficient C3,D3, …J3.

Chacune des notes sur les 8 questions a un coefficient (qui peut être modifiable). L’enseignant peut décider de donner plus de poids à une question par rapport à une autre.

Ce n’est pas une moyenne calculée à partir de la fonction MOYENNE qui se base sur des coefficients tous égaux entre eux.

(1) On calcule d’abord la somme des coefficients (que l’on met dans L3). 
Dans L3, on aura la formule =>          =SOMME(C3:J3)
La somme des coefficients est 9.

(2) On met dans C4 à J4, la note maximale de 10 pour le meilleur élève.

(3) On écrit la formule dans L4 qui permet de calculer la moyenne de ce meilleur élève.
Dans L4, si la formule est bonne on doit trouver comme moyenne 20.

La formule mise est =>
=(C3*C4+D3*D4+E3*E4+F3*F4+G3*G4+H3*H4+I3*I4+J3*J4)/L3*2

(4) On copie la formule L4 dans L5 (pr le calcul de la moyenne de la moyenne de l’élève AMATO)

(5) On double-clique sur la formule dans L5, et on devrait s’apercevoir que lec copier/coller a permis d’obtenir la formule suivante
=(C4*C5+D4*D5+E4*E5+F4*F5+G4*G5+H4*H5+I4*I5+J4*J5)/L4*2

On s’aperçoit (avec le jeu des couleurs sur Libre Office que ce ne sont pas les coefficients qui sont correctement pris, ni la somme des coefficients)
On devrait plutôt avoir la formule suivante
=(C3*C5+D3*D5+E3*E5+F3*F5+G43*G5+H3*H5+I3*I5+J3*J5)/L3*2

(6) On se remet sur la formule de la cellule L4, et on modifie de la manière suivante
=(C$3*C4+D$3*D4+E$3*E4+F$3*F4+G$3*G4+H$3*H4+I$3*I4+J$3*J4)/L$3*2

(7) On copie à nouveau la formule L4 dans L5 (pr le calcul de la moyenne de la moyenne de l’élève AMATO)
et on vérifie en doublecliquant sur L5 que cette formule collée utilise les bons paramètres.

(8) Il n’y a plus qu’à recopier la formule de L4 sur les autres cellules : L6 à L25.

(9) On en profite pour remettre les bonnes couleurs dans les moyennes calculées et présenter les résultats avec 2 décimales (pour un affichage plus propre)   (voir fichier résultat définitif (exo2.corrige.ods

Copier et coller des résultats obtenus par des formules

Il est parfois nécessaire de copier les résultats de formules (par exemple des moyennes) à un autre endroit d’un feuille de calcul. Si on passe par un ‘bête’ copier/coller, on risque de recopier la formule vers ce nouvel endroit et donc d’obtenir des choses non voulues. Si on veut copier les résultats (par exemple des résultats qui sont des nombres dans notre cas), il faut utiliser le copier, puis le collage spécial. Et dans le collage spécial, on indique qu’il faut coller les nombres qui sont résultats. 

Tableaux croisés dynamiques

 Quelques liens pour ceux qui n’étaient pas en cours 

 

Fonctions utiles

Il donne quelques exemples d’application de ces fonctions.

 

Autres tutos disponibles